Hl7.Fhir.Conformance 5.0.0-beta1

Prefix Reserved
This is a prerelease version of Hl7.Fhir.Conformance.
There is a newer version of this package available.
See the version list below for details.
dotnet add package Hl7.Fhir.Conformance --version 5.0.0-beta1                
NuGet\Install-Package Hl7.Fhir.Conformance -Version 5.0.0-beta1                
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Hl7.Fhir.Conformance" Version="5.0.0-beta1" />                
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Hl7.Fhir.Conformance --version 5.0.0-beta1                
#r "nuget: Hl7.Fhir.Conformance, 5.0.0-beta1"                
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Hl7.Fhir.Conformance as a Cake Addin
#addin nuget:?package=Hl7.Fhir.Conformance&version=5.0.0-beta1&prerelease

// Install Hl7.Fhir.Conformance as a Cake Tool
#tool nuget:?package=Hl7.Fhir.Conformance&version=5.0.0-beta1&prerelease                

Build Status

IMPORTANT The 5.0 version of the SDK contains substantial changes to the way we have organized the NuGet packages and source code. Please read before installing this new 5.0 version.

IMPORTANT Version 5.0 of the SDK is in beta. Navigate back to the main repository for the stable 4.x release.

Introduction

This is Firely's official support SDK for working with HL7 FHIR on the Microsoft .NET (dotnet) platform.

This SDK provides:

  • Class models for working with the FHIR data model using POCO's
  • Xml and Json parsers and serializers
  • A REST client for working with FHIR-compliant servers
  • Helper classes to work with the specification metadata, most notably StructureDefinition and generation of differentials
  • Validation of instances based on profiles
  • Evaluation FhirPath expressions

Release notes

Read the releases notes on firely-net-sdk/releases. You can find documentation about this SDK in the Firely docs site.

Getting Started

Before installing one of the NuGet packages (or clone the repo) it is important to understand that HL7 has published several updates of the FHIR specification, each with breaking changes - so you need to ensure you use the version that is right for you:

  • DSTU1 (published September 2014) is mostly obsolete and we are no longer maintaining this library for DSTU1.
  • DSTU2 (published October 2015) is mostly obsolete and and we are no longer maintaining this library for DSTU2.
  • STU3 (published March 2017) is older, but still widely in use. Is fully supported by this library.
  • R4 (published January 2019) is in active use and fully supported by this library.
  • R4B (published May 2022) is the latest official release of the FHIR spec and is fully supported by this library.
  • R5 (not yet published) is work-in-progress. This library currently supports "snapshot-1".

Planned release DSTU2.1 was never published by HL7, but you will still find traces of it. We are not maintaining the version, but the NuGet package is still available.

Read the online documentation, and download the correct NuGet package for your FHIR release. Depending on the version of FHIR you require, you'll find the relevant link to the package below. For most developers, just including this NuGet package is enough to get started.

Spec version Git branch NuGet
R5 https://github.com/FirelyTeam/firely-net-sdk/tree/release/5.0.0 https://www.nuget.org/packages/Hl7.Fhir.R5
R4B https://github.com/FirelyTeam/firely-net-sdk/tree/release/5.0.0 https://www.nuget.org/packages/Hl7.Fhir.R4B
R4 https://github.com/FirelyTeam/firely-net-sdk/tree/release/5.0.0 https://www.nuget.org/packages/Hl7.Fhir.R4
STU3 https://github.com/FirelyTeam/firely-net-sdk/tree/release/5.0.0 https://www.nuget.org/packages/Hl7.Fhir.STU3
DSTU2 https://github.com/FirelyTeam/firely-net-sdk/tree/develop-dstu2 https://www.nuget.org/packages/Hl7.Fhir.DSTU2

Upgrading

We spend a lot of effort trying to maintain compile compatibility (not binary compatibility) between minor releases of the SDK. We do, however, publish a new major version with breaking changes about once a year. The table below lists the breaking changes for each of the major upgrades.

SDK version Breaking changes
2.x https://github.com/FirelyTeam/firely-net-sdk/wiki/Breaking-changes-in-2.0
3.x https://github.com/FirelyTeam/firely-net-sdk/wiki/Breaking-changes-in-3.0
4.x https://github.com/FirelyTeam/firely-net-sdk/wiki/Breaking-changes-in-4.0
5.x https://github.com/FirelyTeam/firely-net-sdk/wiki/Breaking-changes-in-5.0

The SDK has been totally restructured for the 5.0 release. Please take not of the following changes if you are upgrading:

  • The additional Hl7.Fhir.Specification packages are no longer relevant starting at version 5.0 of the SDK and should not be included in your projects anymore.
  • The main NuGet package no longer contains the specification.zip file that contains all the conformance resources used in the FHIR specification. If you are using the ZipSource resolvers (e.g. for profile validation), you will need to include the correct HL7.Fhir.Specification.Data.* NuGet packages. We recommend you look at the newer FhirPackageResolver that directly use the HL7-published NPM packages. Documentation can be found here.
  • The profile validator has been split off into its own repository. The NuGet packages for the 5.0 version of the profile validator will be posted soon.

Support

We actively monitor the issues coming in through the GitHub repository at https://github.com/FirelyTeam/firely-net-sdk/issues. You are welcome to register your bugs and feature suggestions there. For questions and broader discussions, we use the .NET FHIR Implementers chat on Zulip.

Contributing

We are welcoming contributions!

If you want to participate in this project, we're using Git Flow for our branch management. Please submit PRs with changes against the develop branche.

Note: Since the 5.0 release of the SDK, the branches for STU3 and newer have been combined in a single develop branch. This branch now contains the code for all FHIR releases from STU3 and up. We have also refactored all the common code out to projects within that branch, so the separate common repository (at https://github.com/FirelyTeam/firely-net-common) is no longer in use. This greatly simplifies management and creating PRs for these projects.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (9)

Showing the top 5 NuGet packages that depend on Hl7.Fhir.Conformance:

Package Downloads
Hl7.Fhir.R4

Firely's SDK for working with HL7 FHIR R4. This is the root package for the SDK includes core functionality to working with RESTful FHIR servers, POCO classes for FHIR, parsing/serialization of FHIR data and working with conformance data and terminologies.

Hl7.Fhir.R4B

Firely's SDK for working with HL7 FHIR R4B. This is the root package for the SDK includes core functionality to working with RESTful FHIR servers, POCO classes for FHIR, parsing/serialization of FHIR data and working with conformance data and terminologies.

Hl7.Fhir.R5

Firely's SDK for working with HL7 FHIR R5. This is the root package for the SDK includes core functionality to working with RESTful FHIR servers, POCO classes for FHIR, parsing/serialization of FHIR data and working with conformance data and terminologies.

Firely.Fhir.Validation.Compilation

Next-gen Firely validation ElementSchema compiler for R4 and later.

brianpos.Fhir.R4B.DemoFileSystemFhirServer

Demonstration implementation of a FHIR R4 Facade using the file system as a super simple storage provider

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
5.9.0 25 7/25/2024
5.8.2 6,827 7/10/2024
5.8.1 87,075 5/2/2024
5.8.0 10,975 4/24/2024
5.7.0 71,739 3/15/2024
5.6.1 66,717 2/13/2024
5.6.0 1,583 2/13/2024
5.5.1 70,274 1/16/2024
5.5.0 21,656 1/10/2024
5.4.0 147,076 10/26/2023
5.3.0 210,592 7/27/2023
5.2.0 109,362 5/26/2023
5.1.0 61,499 4/28/2023
5.0.0 226,580 2/17/2023
5.0.0-beta3 1,653 2/1/2023
5.0.0-beta2 886 1/19/2023
5.0.0-beta1 3,918 12/21/2022