Flandre.Framework 0.7.1

There is a newer version of this package available.
See the version list below for details.
dotnet add package Flandre.Framework --version 0.7.1
NuGet\Install-Package Flandre.Framework -Version 0.7.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Flandre.Framework" Version="0.7.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Flandre.Framework --version 0.7.1
#r "nuget: Flandre.Framework, 0.7.1"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Flandre.Framework as a Cake Addin
#addin nuget:?package=Flandre.Framework&version=0.7.1

// Install Flandre.Framework as a Cake Tool
#tool nuget:?package=Flandre.Framework&version=0.7.1

Flandre

.NET 6 实现的跨平台,现代化聊天机器人框架
一次编写,多处运行

License Stars Contributors .NET Version Codecov

- 使用文档 -

本项目的名称来源于东方 Project 中的角色芙兰朵露 · 斯卡雷特 (Flandre Scarlet) (番茄炒蛋)


项目的完整 README 可在 GitHub 上查看


项目仍在早期开发阶段,功能尚未完善,且处于快速迭代过程中。
如果您对项目的开发感兴趣,诚挚欢迎您的改进建议或 PR 贡献。

1.0 版本发布前随时可能发生 API 的非兼容性变更,不建议用于生产环境。

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (7)

Showing the top 5 NuGet packages that depend on Flandre.Framework:

Package Downloads
Flandre.Plugins.WolframAlpha

Wolfram Alpha non-commercial API plugin for Flandre.

Flandre.Plugins.HttpCat

HttpCat plugin for Flandre.

Flandre.Plugins.BaiduTranslate

Baidu Translate plugin for Flandre.

Flandre.Framework.Reactive

Reactive Extensions (Rx.NET) support for Flandre.Framework.

Flandre.Adapters.OneBot.Extensions

Flandre.Framework extensions for Flandre.Adapters.OneBot.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.0-rc.11 76 6/15/2023
1.0.0-rc.10 68 6/4/2023
1.0.0-rc.9 83 5/5/2023
1.0.0-rc.8 73 4/28/2023
1.0.0-rc.7 76 4/19/2023
1.0.0-rc.6 96 4/10/2023
1.0.0-rc.5 78 4/10/2023
1.0.0-rc.4 76 4/9/2023
1.0.0-rc.3 74 4/9/2023
1.0.0-rc.2 76 4/9/2023
1.0.0-rc.1 90 3/12/2023
1.0.0-alpha.7 87 3/4/2023
1.0.0-alpha.6 78 3/4/2023
1.0.0-alpha.5 89 3/3/2023
1.0.0-alpha.4 88 3/1/2023
1.0.0-alpha.3 84 2/28/2023
1.0.0-alpha.2 85 2/26/2023
1.0.0-alpha.1 82 2/24/2023
0.8.0 314 1/10/2023
0.8.0-beta 137 1/9/2023
0.8.0-alpha.1 97 1/8/2023
0.7.1 678 12/3/2022
0.7.0 317 11/29/2022