TestableFileSystem.Wrappers 2.0.1

.NET Standard 1.3 .NET Framework 4.5
NuGet\Install-Package TestableFileSystem.Wrappers -Version 2.0.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
dotnet add package TestableFileSystem.Wrappers --version 2.0.1
<PackageReference Include="TestableFileSystem.Wrappers" Version="2.0.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add TestableFileSystem.Wrappers --version 2.0.1
#r "nuget: TestableFileSystem.Wrappers, 2.0.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install TestableFileSystem.Wrappers as a Cake Addin
#addin nuget:?package=TestableFileSystem.Wrappers&version=2.0.1

// Install TestableFileSystem.Wrappers as a Cake Tool
#tool nuget:?package=TestableFileSystem.Wrappers&version=2.0.1

Implements TestableFileSystem.Interfaces by forwarding to the .NET Framework or .NET Core.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp1.0 netcoreapp1.1 netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard1.3 netstandard1.4 netstandard1.5 netstandard1.6 netstandard2.0 netstandard2.1
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen30 tizen40 tizen60
Universal Windows Platform uap uap10.0
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on TestableFileSystem.Wrappers:

Package Downloads
ResharperCodeContractNullability

Reports diagnostics, helping you to annotate your source tree with (Item)NotNull / (Item)CanBeNull attributes. See also: https://www.jetbrains.com/resharper/help/Code_Analysis__Code_Annotations.html You need Visual Studio 2015/2017/2019 and Resharper v9 or higher to use this analyzer. See package "ResharperCodeContractNullabilityFxCop" if you use Visual Studio 2013 or lower.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.0.1 1,574 5/4/2019
2.0.0 373 5/1/2019
1.0.0 1,520 12/14/2017

Crashfix in code analyzer.