NetSparkleUpdater.Tools 2.0.0-preview20210131001

Tools for the NetSparkle software updater (DSA helper and app cast generator) -- requires .NET Core 3.1 Desktop Runtime. NetSparkleUpdater/NetSparkle is a C# .NET software update framework that allows you to easily download installer files and update your C# .NET Framework or .NET Core software. Built-in UIs are available for WinForms, WPF, and Avalonia. You provide, somewhere on the internet, an XML appcast with software version information along with release notes in Markdown or HTML format. The NetSparkle framework then checks for an update in the background, displays the release notes to the user, and lets users download or skip the software update. The framework can also perform silent downloads so that you can present all of the UI yourself or set up your own silent software update system, as allowed by your software architecture. It was inspired by the Sparkle (https://sparkle-project.org/) project for Cocoa developers and the WinSparkle (https://winsparkle.org/) project (a Win32 port).

Suggested Alternatives

NetSparkleUpdater.Tools.AppCastGenerator

Additional Details

Thanks for using the NetSparkleUpdater tools package! We are now hosting these tools in SEPARATE NuGet packages so that they can be easily updated and so that they work as .NET global CLI tools! :) Use NetSparkleUpdater.Tools.AppCastGenerator for your Ed25519 tools and app cast generation. Use NetSparkleUpdater.Tools.DSAHelper for your DSA tools.

This is a prerelease version of NetSparkleUpdater.Tools.
The owner has unlisted this package. This could mean that the package is deprecated, has security vulnerabilities or shouldn't be used anymore.
Install-Package NetSparkleUpdater.Tools -Version 2.0.0-preview20210131001
dotnet add package NetSparkleUpdater.Tools --version 2.0.0-preview20210131001
<PackageReference Include="NetSparkleUpdater.Tools" Version="2.0.0-preview20210131001" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NetSparkleUpdater.Tools --version 2.0.0-preview20210131001
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: NetSparkleUpdater.Tools, 2.0.0-preview20210131001"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install NetSparkleUpdater.Tools as a Cake Addin
#addin nuget:?package=NetSparkleUpdater.Tools&version=2.0.0-preview20210131001&prerelease

// Install NetSparkleUpdater.Tools as a Cake Tool
#tool nuget:?package=NetSparkleUpdater.Tools&version=2.0.0-preview20210131001&prerelease
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

[DEPRECATED] We now have a new repo, new name, and new package. Join us for the official 2.0 NetSparkle update with new features and enhancements! 😃 https://github.com/NetSparkleUpdater/NetSparkle/

[DEPRECATED] We now have a new repo, new name, and new package. Join us for the official 2.0 NetSparkle update with new features and enhancements! 😃 https://github.com/NetSparkleUpdater/NetSparkle/

Release Notes

2.0 Beta: See https://github.com/NetSparkleUpdater/NetSparkle for all beta information and to file issues/pull requests for and ask questions about this project. Requires .NET Core 3 desktop runtime to be installed.

Dependencies

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated