Message.Router 1.0.5

.NET Standard 1.3 .NET Framework 4.5
Install-Package Message.Router -Version 1.0.5
dotnet add package Message.Router --version 1.0.5
<PackageReference Include="Message.Router" Version="1.0.5" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Message.Router --version 1.0.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Message.Router, 1.0.5"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Message.Router as a Cake Addin
#addin nuget:?package=Message.Router&version=1.0.5

// Install Message.Router as a Cake Tool
#tool nuget:?package=Message.Router&version=1.0.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

A lightweight message routing library supporting various messaging frameworks and serialization formats.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp1.0 netcoreapp1.1 netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard1.3 netstandard1.4 netstandard1.5 netstandard1.6 netstandard1.7 netstandard2.0 netstandard2.1
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen30 tizen40 tizen60
Universal Windows Platform uap uap10.0
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETFramework 4.5

    • No dependencies.
  • .NETFramework 4.5.1

    • No dependencies.
  • .NETFramework 4.5.2

    • No dependencies.
  • .NETFramework 4.6

    • No dependencies.
  • .NETFramework 4.6.1

    • No dependencies.
  • .NETFramework 4.6.2

    • No dependencies.
  • .NETFramework 4.7

    • No dependencies.
  • .NETFramework 4.7.1

    • No dependencies.
  • .NETStandard 1.3

    • No dependencies.
  • .NETStandard 1.4

    • No dependencies.
  • .NETStandard 1.5

    • No dependencies.
  • .NETStandard 1.6

    • No dependencies.
  • .NETStandard 1.7

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Message.Router:

Package Downloads
Message.Router.NetMQ

A NetMQ support for the Message.Router library.

Message.Router.Json

A JSON serialization support for the Message.Router library.

Message.Router.Xml

A XML serialization support for the Message.Router library.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.5 11,738 5/13/2018
1.0.4 1,125 5/9/2018
1.0.3 678 5/7/2018
1.0.2 695 5/6/2018
1.0.1 651 5/6/2018
1.0.0 1,176 5/6/2018

Increased number of supported platforms (.NET Framework, .NET standard). Improved routing for event messages.