ManagedWimLib 2.4.0

.NET Core 3.1 .NET Standard 2.0 .NET Framework 4.5.1
Install-Package ManagedWimLib -Version 2.4.0
dotnet add package ManagedWimLib --version 2.4.0
<PackageReference Include="ManagedWimLib" Version="2.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add ManagedWimLib --version 2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: ManagedWimLib, 2.4.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install ManagedWimLib as a Cake Addin
#addin nuget:?package=ManagedWimLib&version=2.4.0

// Install ManagedWimLib as a Cake Tool
#tool nuget:?package=ManagedWimLib&version=2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Usage

Please refer to this document.

Tested wimlib Versions

  • 1.13.5 (Included)

Support

Targeted .NET platforms

  • .NET Core 3.1
  • .NET Standard 2.0
  • .NET Framework 4.5.1

If you need .NET Standard 1.3 support, use 1.2.x version instead. If you need .NET Framework 4.5 support, use 1.1.x version instead.

Supported OS platforms

  • Windows x86, x64, arm64
  • Linux x64, arm, arm64
  • macOS x64, arm64
Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories (3)

Showing the top 3 popular GitHub repositories that depend on ManagedWimLib:

Repository Stars
WOA-Project/WoA-Installer-Rpi
This repository was deprecated, use:
gus33000/UUPMediaCreator
An utility to create Windows Media files (.ISO, .WIM, .VHD) from Unified Update Platform files
pebakery/pebakery
PEBakery is a script engine that specializes in customizing the Windows Preinstalled Environment (WinPE/WinRE).
Version Downloads Last updated
2.4.0 1,156 2/14/2022
2.3.0 90 1/27/2022
2.2.0 1,590 5/15/2021
2.1.0 244 4/9/2021
2.0.1 851 6/6/2020
2.0.0 304 6/6/2020
1.4.3 5,275 10/31/2019
1.4.2 306 10/25/2019
1.4.1 290 10/20/2019
1.4.0 304 10/20/2019
1.3.0 725 5/9/2019
1.2.4 1,511 12/5/2018
1.2.3 557 10/30/2018
1.2.2 568 10/29/2018
1.2.1 648 10/18/2018
1.2.0 558 10/15/2018
1.1.2 586 10/14/2018
1.1.1 557 10/13/2018
1.1.0 746 9/5/2018
1.0.0 1,410 5/22/2018

- Official support for ARM64 macOS.
- Replace .NET Standard 2.1 target with .NET Core 3.1.