Beckhoff.TwinCAT.Ads.Abstractions 6.1.197

The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org. Prefix Reserved
dotnet add package Beckhoff.TwinCAT.Ads.Abstractions --version 6.1.197
NuGet\Install-Package Beckhoff.TwinCAT.Ads.Abstractions -Version 6.1.197
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Beckhoff.TwinCAT.Ads.Abstractions" Version="6.1.197" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Beckhoff.TwinCAT.Ads.Abstractions --version 6.1.197
#r "nuget: Beckhoff.TwinCAT.Ads.Abstractions, 6.1.197"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Beckhoff.TwinCAT.Ads.Abstractions as a Cake Addin
#addin nuget:?package=Beckhoff.TwinCAT.Ads.Abstractions&version=6.1.197

// Install Beckhoff.TwinCAT.Ads.Abstractions as a Cake Tool
#tool nuget:?package=Beckhoff.TwinCAT.Ads.Abstractions&version=6.1.197

Description

The package 'Beckhoff.TwinCAT.Ads.Abstractions' contains interfaces and base implementations for the 'Beckhoff.TwinCAT.Ads.Server' and 'Beckhoff.TwinCAT.Ads' packages. It is never used standalone and is a dependency of the above-named packages.

Requirements

  • .NET 7.0, .NET 6.0 or .NET Standard 2.0 (e.g. >= .NET Framework 4.61) compatible SDK
  • A TwinCAT 3.1.4024 Build.
  • or alternatively for systems where a TwinCAT installation is not running the Nuget package 'Beckhoff.TwinCAT.Ads.AdsRouterConsole'. to route ADS communication.
  • Installed Nuget package manager (for systems without Visual Studio installation)

Version Support lifecycle

Package Description .NET Framework TwinCAT Active Support
6.1 Package basing on .NET 7.0/6.0 net7.0, net6.0, netstandard2.0 >= 3.1.4024.10 [^1] X
6.0 Package basing on .NET 6.0 net6.0, netcoreapp3.1, netstandard2.0, net461 >= 3.1.4024.10 [^1] X
5.x Package basing on .NET 5.0[^3] net5.0, netcoreapp3.1, netstandard2.0, net461 >= 3.1.4024.10 [^1]
4.x Package basing on .NET Framework 4.0 net4 All X

[^1]: Requirement on the Host system. No version limitation in remote system communication.

[^2]: Microsoft support for .NET5 ends with May 8, 2022. Therefore it is recommended to update Beckhoff.TwinCAT packages from Version 5 to Version 6.

Migrate from ASP.NET Core 5.0 to 6.0

migrating to the latest .NET Microsoft .NET support lifecycle

Installation

As dependency of other Beckhoff packages

Further documentation

The actual version of the documentation is available in the Beckhoff Infosys. Beckhoff Information System

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 is compatible.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (7)

Showing the top 5 NuGet packages that depend on Beckhoff.TwinCAT.Ads.Abstractions:

Package Downloads
Beckhoff.TwinCAT.Ads.Server The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

The Beckhoff.TwinCAT.AdsServer Package can be used to implement your own ADS Server.

Beckhoff.TwinCAT.Ads.Reactive The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

Reactive extensions for Beckhoff.TwinCAT.AdsClient Extends the AdsClient object with Reactive Interfaces for ADS Notifications to support observable Streams of value changes.

Beckhoff.TwinCAT.Ads.TcpRouter The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

ADS (TCP) Router implementation. This package can be used for ADS router functionality on targets that doesn't run TwinCAT Installations to communicate to local and remote ADS targets.

Beckhoff.TwinCAT.Ads.SymbolicServer The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

The Beckhoff.TwinCAT.Ads.SymbolicServer Package can be used to implement your own ADS Server.

CovisartMotionSimulatorSDK

Covisart Motion Simulator Software Development Kit

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
6.1.197 1,999 2/12/2024
6.1.154 9,943 12/8/2023
6.1.125 3,874 11/23/2023
6.0.356 427 2/12/2024
6.0.334 852 12/8/2023
6.0.322 540 11/23/2023

Enh: Replaces .NET7 dependency by .NET8