AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK 1.0.0

dotnet add package AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK --version 1.0.0
NuGet\Install-Package AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK -Version 1.0.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK" Version="1.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK --version 1.0.0
#r "nuget: AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK, 1.0.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK as a Cake Addin
#addin nuget:?package=AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK&version=1.0.0

// Install AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK as a Cake Tool
#tool nuget:?package=AjsWebDesign.DVLA.VEHICLE.ENQUIRY.SDK&version=1.0.0

DVLA.VEHICLE.ENQUIRY.SDK

A simple SDK for access to the DVLA Vehicle Enquiry API

Installation

To be able to use this SDK, you will require an Api Key, which you can apply for from the DVLA.

DVLA.VEHICLE.ENQUIRY.SDK is available from NuGet or as a manual download directly from GitHub.

Usage

You will need to add the following key to your appsettings.json or secrets.json:

  {
    "DvlaVehicleEnquiryApi": {
      "DVLAApiKey": "YOUR KEY HERE"
    }
  }
 

Then you will then need to register the apikey and SDK in your Startup.cs file

  services.Configure<ApiKey>(Configuration.GetSection("DvlaVehicleEnquiryApi"));
  services.AddDvlaVehicleEnquirySdk();
  services.AddOptions();
  services.AddLogging();

Documentation

Documentation and examples on how the parameters are used to access the api can be found on the dvla vehicle enquiry api website: https://developer-portal.driver-vehicle-licensing.api.gov.uk/apis/vehicle-enquiry-service/v1.1.0-vehicle-enquiry-service.html#vehicle-enquiry-api

Contribution guidelines

To raise a new bug, create an issue on the GitHub repository. To fix a bug or add new features, fork the repository and send a pull request with your changes. Feel free to add ideas to the repository's issues list if you would to discuss anything related to the package.

License

Copyright © 2020 Aaron Sadler.

Licensed under the MIT License.

The DVSA API is Licensed under the Open Government Licence v3.0

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.1 is compatible. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETStandard 2.1

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.0 494 5/19/2020

1.0.0 Initial release