Nager.PublicSuffix 2.4.0 The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org. Prefix Reserved

.NET 6.0 .NET Standard 2.0
Install-Package Nager.PublicSuffix -Version 2.4.0
dotnet add package Nager.PublicSuffix --version 2.4.0
<PackageReference Include="Nager.PublicSuffix" Version="2.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Nager.PublicSuffix --version 2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Nager.PublicSuffix, 2.4.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Nager.PublicSuffix as a Cake Addin
#addin nuget:?package=Nager.PublicSuffix&version=2.4.0

// Install Nager.PublicSuffix as a Cake Tool
#tool nuget:?package=Nager.PublicSuffix&version=2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Domain parsing and validating (TLD, domain, subdomain) provide easy and fast access to Public Suffix List

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETStandard 2.0

    • No dependencies.
  • net6.0

    • No dependencies.

NuGet packages (6)

Showing the top 5 NuGet packages that depend on Nager.PublicSuffix:

Package Downloads
SharpPulsar

SharpPulsar is Apache Pulsar Client built using Akka.net

fbognini.Infrastructure

Package Description

OneRow.Utils

Utility Library for lot of stuff. Use as-is, no support.

AnimeDl

AnimeDl scrapes animes from sites for streaming or downloading.

OneRow.Utils.NetworkManager

Some Network Utilities. Use as-is. No support.

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on Nager.PublicSuffix:

Repository Stars
win-acme/win-acme
A simple ACME client for Windows (for use with Let's Encrypt et al.)
Version Downloads Last updated
2.4.0 21,183 5/31/2022
2.3.0 70,142 2/18/2022
2.2.2 242,463 2/9/2021
2.2.1 1,393 2/9/2021
2.2.0 280 2/8/2021
2.1.0 1,542 1/30/2021
2.0.3 15,888 12/30/2020
1.5.1 309,823 2/10/2020
1.5.0 60,614 10/1/2019
1.4.0 2,003 9/17/2019
1.3.1 53,404 6/28/2019
1.3.0 90,960 11/1/2018
1.2.2 25,435 6/30/2018
1.2.1 730 6/29/2018
1.2.0 9,629 3/12/2018
1.1.1 794 3/7/2018
1.1.0 10,180 9/27/2017
1.0.4 17,967 6/17/2017
1.0.3 1,934 3/12/2017
1.0.2 1,657 12/2/2016
1.0.1 812 11/27/2016
1.0.0 1,322 10/27/2016

Add IEquatable Interface to TldRule.cs