NSW.EliteDangerous.INARA 1.0.0

.NET Standard 2.0
Install-Package NSW.EliteDangerous.INARA -Version 1.0.0
dotnet add package NSW.EliteDangerous.INARA --version 1.0.0
<PackageReference Include="NSW.EliteDangerous.INARA" Version="1.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NSW.EliteDangerous.INARA --version 1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: NSW.EliteDangerous.INARA, 1.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install NSW.EliteDangerous.INARA as a Cake Addin
#addin nuget:?package=NSW.EliteDangerous.INARA&version=1.0.0

// Install NSW.EliteDangerous.INARA as a Cake Tool
#tool nuget:?package=NSW.EliteDangerous.INARA&version=1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

<img src="https://i.imgur.com/qA5ubgH.png" align="right" title="Frontier Elite Dangerous INARA" width="280">

Frontier Elite Dangerous API

NugetNuget (with prereleases)Nuget

GitHub top languageGitHubGitHub Release DateGitHub last commit

Intro

Simple library for INARA integration based on documentation.

Usage

Use AddEliteDangerousINARA() method to add API into your app:

// Use Microsoft.Extensions.DependencyInjection
 var inara = new ServiceCollection()
                .AddLogging(cfg => cfg.AddDebug())
                .Configure<LoggerFilterOptions>(cfg => cfg.MinLevel = LogLevel.Warning)
                .AddEliteDangerousINARA(o =>
                {
                    o.ApiKey = "your_apikey_from_inara";
                    o.ApplicationName = "your_application_name";
                    o.ApplicationVersion = "1.2.3";
                    o.IsDevelopment = true; // set this while you debugging
                })
                .BuildServiceProvider()
                .GetService<IEliteDangerousINARA>();

or with known Commander

// Use Microsoft.Extensions.DependencyInjection
 var inara = new ServiceCollection()
                .AddLogging(cfg => cfg.AddDebug())
                .Configure<LoggerFilterOptions>(cfg => cfg.MinLevel = LogLevel.Warning)
                .AddEliteDangerousINARA(o =>
                {
                    o.ApiKey = "your_apikey_from_inara";
                    o.ApplicationName = "your_application_name";
                    o.ApplicationVersion = "1.2.3";
                    o.Commander = "Your Commander";
                    o.FrontierId = "F1234567"; // this optional
                })
                .BuildServiceProvider()
                .GetService<IEliteDangerousINARA>();
Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.0 314 9/26/2019