NBench.Runner 1.0.2

NBench is a cross-platform automated performance profiling and testing framework for.NET applications.

There is a newer version of this package available.
See the version list below for details.
Install-Package NBench.Runner -Version 1.0.2
dotnet add package NBench.Runner --version 1.0.2
<PackageReference Include="NBench.Runner" Version="1.0.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NBench.Runner --version 1.0.2
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: NBench.Runner, 1.0.2"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install NBench.Runner as a Cake Addin
#addin nuget:?package=NBench.Runner&version=1.0.2

// Install NBench.Runner as a Cake Tool
#tool nuget:?package=NBench.Runner&version=1.0.2
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

This release resolves issues: [#182](https://github.com/petabridge/NBench/issues/182) and [#192](https://github.com/petabridge/NBench/issues/192) relating to the NBench.Runner.DotNetCli (the NBench Runner that can execute benchmarks for assemblies that target .NET Core).  The root cause was that the runner was unable to execute .NET Core benchmarks that had external dependencies.
Other changes include:
- Integration tests to validate that the above issue is resolved
- Upgrade to xUnit .NET Core CLI runner (v2.3.0-beta2-build3683) for all NBench unit tests
- Update .NET Core runtime targets to `netcoreapp1.1`
If you are using the .NET Core CLI runner for NBench and encountered this issue, please be sure to update your `<DotNetCliToolReference>` to v1.0.2:
```
<ItemGroup>
<DotNetCliToolReference Include="NBench.Runner.DotNetCli" Version="1.0.2" />
</ItemGroup>
```

Dependencies

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on NBench.Runner:

Repository Stars
cuteant/SpanNetty
Port of Netty(v4.1.51.Final) for .NET

Version History

Version Downloads Last updated
1.2.2 35,158 7/24/2018
1.2.1 1,759 7/11/2018
1.2.0 690 7/10/2018
1.1.0 3,710 7/2/2018
1.0.4 12,364 6/16/2017
1.0.3 799 6/10/2017
1.0.2 631 6/2/2017
1.0.1 4,916 3/31/2017
1.0.0 1,338 3/15/2017
0.3.4 3,590 12/16/2016
0.3.3 4,537 12/8/2016
0.3.2 672 12/8/2016
0.3.1 10,203 8/16/2016
0.3.0 2,875 5/24/2016
0.2.2 960 5/3/2016
0.2.1 1,561 4/7/2016
0.2.0 638 4/6/2016
0.1.6 6,815 2/15/2016
0.1.5 2,641 12/10/2015
0.1.4 649 12/10/2015
0.1.3 662 12/8/2015
0.1.2 685 12/8/2015
0.1.1 656 12/7/2015
0.1.0 666 12/5/2015
Show less