Fen.Service 4.1.0-pre1

Standardized Service conventions, from the opinions of the Fulfiller Enablement team.

This is a prerelease version of Fen.Service.
There is a newer version of this package available.
See the version list below for details.
Install-Package Fen.Service -Version 4.1.0-pre1
dotnet add package Fen.Service --version 4.1.0-pre1
<PackageReference Include="Fen.Service" Version="4.1.0-pre1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Fen.Service --version 4.1.0-pre1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Fen.Service, 4.1.0-pre1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Fen.Service as a Cake Addin
#addin nuget:?package=Fen.Service&version=4.1.0-pre1&prerelease

// Install Fen.Service as a Cake Tool
#tool nuget:?package=Fen.Service&version=4.1.0-pre1&prerelease
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

➟ Release 4.1.0
⁃ The Fen.Authorization library is fully opt-in, and none of its functionality is a dependency to this project.
⁃ AWS X-Ray tracing is integrated into the conventions.

➟ Release 4.0.1
⁃ Healthcheck discoverability has been restored.
⁃ The content type "text/plain" has been un-restored.

➟ Release 4.0.0
⁃ In preparation for hosting on AWS Lambda, a large number of changes have been made to the project.
 ⁃ A customized Lambda entry point has been added.
 ⁃ A local development extension point has been added.
 ⁃ Authentication has been removed in favor of a Lambda Authorizer.
 ⁃ Default CORS rules have been adjusted.
 ⁃ The portions of Auth0 configuration used for generating authentication response headers have been removed.
   ⁃ The remaining properties have been moved into Swashbuckle configuration.
   ⁃ The rules for what an authenticated endpoint is have been altered. (Lacks an `AllowAnonymousAttribute`.)
⁃ The new COAM Conventions are now available by default. (Don't use COAM? No problem. There's no longer a runtime cost.)
⁃ `MinimumAttribute` and `MaximumAttribute` are now exposed to Swagger definition builders.
⁃ ASP.NET Core 2.1 conventions have been applied.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
6.0.0 153 8/16/2021
6.0.0-rc1 67 8/12/2021
5.0.0 695 6/22/2021
5.0.0-rc8 521 4/29/2021
5.0.0-rc7 375 3/29/2021
5.0.0-rc6 95 3/25/2021
5.0.0-rc5 96 3/24/2021
5.0.0-rc4 213 3/19/2021
5.0.0-rc3 138 3/19/2021
5.0.0-rc2 103 3/18/2021
5.0.0-rc1 114 3/11/2021
4.3.1 2,533 12/20/2019
4.3.0 3,208 7/2/2019
4.2.3 1,147 5/2/2019
4.2.2 1,839 2/18/2019
4.2.2-pre1 538 1/29/2019
4.2.1 558 1/18/2019
4.2.0 24,448 11/1/2018
4.1.2 8,183 8/27/2018
4.1.1 467 8/27/2018
4.1.1-pre2 455 8/27/2018
4.1.1-pre1 428 8/27/2018
4.1.0-pre4 435 8/24/2018
4.1.0-pre3 444 8/24/2018
4.1.0-pre2 471 8/22/2018
4.1.0-pre1 468 8/21/2018
4.0.1 884 7/24/2018
4.0.0 546 7/20/2018
4.0.0-preview7-1 533 7/16/2018
4.0.0-preview7 515 7/16/2018
4.0.0-preview6 538 7/16/2018
4.0.0-preview5 532 7/13/2018
4.0.0-preview4 657 6/13/2018
4.0.0-preview3 590 6/12/2018
4.0.0-preview2 798 5/23/2018
4.0.0-preview1 525 5/22/2018
3.0.1 2,679 3/20/2018
3.0.0 584 3/19/2018
2.0.2 1,034 2/19/2018
2.0.1 583 2/19/2018
1.1.1 4,675 1/15/2018
1.1.0 587 12/14/2017
Show less