EntitySecurity 2.3.3

.NET 5.0 .NET Standard 1.0 .NET Framework 4.6
Install-Package EntitySecurity -Version 2.3.3
dotnet add package EntitySecurity --version 2.3.3
<PackageReference Include="EntitySecurity" Version="2.3.3" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add EntitySecurity --version 2.3.3
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: EntitySecurity, 2.3.3"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install EntitySecurity as a Cake Addin
#addin nuget:?package=EntitySecurity&version=2.3.3

// Install EntitySecurity as a Cake Tool
#tool nuget:?package=EntitySecurity&version=2.3.3
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Provides Security Implementation related features, currently a ReferenceMonitor and required interfaces

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp1.0 netcoreapp1.1 netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard1.0 netstandard1.1 netstandard1.2 netstandard1.3 netstandard1.4 netstandard1.5 netstandard1.6 netstandard2.0 netstandard2.1
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen30 tizen40 tizen60
Universal Windows Platform uap uap10.0
Windows Phone wp8 wp81 wpa81
Windows Store netcore netcore45 netcore451
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETFramework 4.6

    • No dependencies.
  • .NETFramework 4.8

    • No dependencies.
  • .NETStandard 1.0

  • .NETStandard 2.0

    • No dependencies.
  • net5.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.3.3 120 1/20/2022
2.3.2 70 1/20/2022
2.3.0 785 11/16/2017
2.2.2 839 3/3/2017
2.1.2 1,083 2/21/2016
2.0.1 1,143 9/18/2015
2.0.0 824 5/29/2015
1.0.4 1,186 2/19/2015
1.0.3 1,131 2/19/2015
1.0.0.1 1,249 7/19/2013

V2.3.3 Add support for .net standard 1.0
V2.3.2 Rework packaging
V2.3.2 Rework packaging
     V2.3.2 Rework packagingV2.3.2 Rework packaging
     V2.3.0 .Net standard support
     V2.1.0 Portable library - Int to Guid conversion bidirectional
     V2.0.1 Revised System Status Exception to retain the originating message text
     V2.3.2 Rework packagingV2.3.2 Rework packaging
V2.3.0 .Net standard support
V2.1.0 Portable library - Int to Guid conversion bidirectional
V2.0.1 Revised System Status Exception to retain the originating message text
V2.0.0 Introduces finer grained permissions for groups; such that a group definition contains the permissible operations for that group.  Added operation to the user and group equivalency interfaces.